We're sorry AsposeApp doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.app

Word with table inside , convert to TXT

this conversion extract all table content as one long string.
how to get this content split by SPACE

Thank you for your feedback.

We managed to complete conversion (from docx to txt) with a simple table on our side, everything worked as expected.
In order to start analysis, could you, please share us a sample source document, and a sample output text document you were expecting to receive.

We apologize for any inconvenience caused.

Its simple like :slight_smile:
Document doc = new Document(file);
doc.Save(“a.txt”,new TxtSaveOptions{})

but, I also try it on yours web site: and same results as I described you

Thanks for the response.

Could you please attach the file? (Which is loaded here -> new Document(file); )

We created a test document in which we added a simple 2x3 table. After that, we converted it to TXT, and the output content (from the table cells) was divided, and not combined together in one long string.

So, probably, there is some feature in your file. To understand this, we need to take a look at your document.

AAAA.docx (12.9 KB)

also, we try t on web site :

same result file downloaded after conversion to txt

The output for you file from https://products.aspose.com/words/net/conversion/word-to-txt/ is also not a “one long string”.
But now we can register your task in our tracker so that the authors of the corresponding code can comment on this situation on their own behalf.

We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): APPS-1288

AAAAA.jpg (65.1 KB)

please see the attched image , the result is one long string.
how ever the is property , TxtSaveOptions.PreserveTableLayout .

just I wonder why you say it work on the online page aspose give for testing .
thanks anyway.

Thanks for the clarifying picture.
This output is different from what is seen on my side. And that in itself is interesting.
Well, let’s wait for a response from our programmers.


just mentioned that we just bougth liecnsed few days ago

Good news.
I hope that soon we will share our analysis on your issue. It is in analysis state now.

As for the expected output, you yourself understood everything correctly, indeed the TxtSaveOptions { PreserveTableLayout = true } option is responsible for this behavior.
Moreover, after an internal conversation, we decided that we will now set the PreserveTableLayout = true value as the default value. For this task, we started APPS-1289 in our tracker.

As for the output in a single line. I asked several people to create this output with the application or directly with Asposy.Words, and no one was able to reproduce the output with a single line of text. Therefore, we have decided to close APPS-1288 with the “Cannot Reproduce” resolution.

Thank you for your patience and all the best.

The issues you have found earlier (filed as APPS-1289) have been fixed. The updated version of the app has been published at https://products.aspose.app/words/family/